VulnTideExploited vulnerabilities, by vendor. Data as of 28 Oct 2026.
Known exploitedIn CISA's KEV catalog since 13 April 2022Ransomware use: known
Drupal Core

CVE-2018-7602: Drupal Core Remote Code Execution Vulnerability

Is it exploited?

Yes. CISA added it to the Known Exploited Vulnerabilities catalog on 13 Apr 2022, 1,364 days after the CVE record was published.

How likely is exploitation in the next 30 days?
99.2%

EPSS score, percentile 99.9 of all scored records

How severe?
8.1 High

CVSS v3.1 base score, from CISA's enrichment of the record

What should I do?

CISA deadline 4 May 2022. Apply updates per vendor instructions.

Advisories and patches (1)

Which versions are affected?

Affected

  • before 7.59
  • before 8.5.3
  • before 8.4.8

Versions by product

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of 28 Oct 2026; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of 28 Oct 2026; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.

What to do

Required action, set by CISA

Apply updates per vendor instructions.

CISA due date for this action: 4 May 2022.

Solution (from the CVE record)

Solution: Upgrade to the most recent version of Drupal 7 or 8 core. If you are running 7.x, upgrade to Drupal 7.59. If you are running 8.5.x, upgrade to Drupal 8.5.3. If you are running 8.4.x, upgrade to Drupal 8.4.8. (Drupal 8.4.x is no longer supported and we don't normally provide security releases for unsupported minor releases. However, we are providing this 8.4.x release so that sites can update as quickly as possible. You should update to 8.4.8 immediately, then update to 8.5.3 or the latest secure release as soon as possible.) If you are unable to update immediately, or if you are running a Drupal distribution that does not yet include this security release, you can attempt to apply the patch below to fix the vulnerability until you are able to update completely: Patch for Drupal 8.x (8.5.x and below) Patch for Drupal 7.x These patches will only work if your site already has the fix from SA-CORE-2018-002 applied. (If your site does not have that fix, it may already be compromised.)

Advisories and patches

Linked from CISA's catalog entry

Affected products and versions

As listed in the CVE record.

Drupal core
StatusVersions
Affectedbefore 7.59
Affectedbefore 8.5.3
Affectedbefore 8.4.8

Versions not listed are: unaffected.

Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.

About this vulnerability

A remote code execution vulnerability exists within multiple subsystems of Drupal that can allow attackers to exploit multiple attack vectors on a Drupal site.

Summary: CISA's KEV catalog, as of 28 Oct 2026.

  • CISA added CVE-2018-7602 to its Known Exploited Vulnerabilities (KEV) catalog on 13 Apr 2022.
  • CISA marks it as known to be used in ransomware campaigns.
  • The due date CISA sets for the required action is 4 May 2022.
  • The CVE record was published on 19 Jul 2018, 1,364 days before it was added to KEV.
  • The CVE record carries a CVSS v3.1 base score of 8.1 (High), taken from CISA's enrichment of the record.
  • FIRST's EPSS model puts the probability of exploitation in the next 30 days at 99.2% (percentile 99.9), as of 28 Oct 2026.
  • CISA's SSVC assessment in the CVE record: exploitation active, automatable no, technical impact total.

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of 28 Oct 2026; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of 28 Oct 2026. About the data.

Description

Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004

A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.

Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record and the KEV entry.

Timeline

DateEvent
19 Jul 2018CVE record published
13 Apr 2022Added to CISA KEV
4 May 2022CISA due date for the required action
1 Oct 2026CVE record last updated

References

More exploited Drupal vulnerabilities

  • CVE-2026-9082: Drupal Core SQL Injection Vulnerability (added 22 May 2026)
  • CVE-2019-6340: Drupal Core Remote Code Execution Vulnerability (added 25 Mar 2022)
  • CVE-2020-13671: Drupal core Un-restricted Upload of File (added 18 Jan 2022)
  • CVE-2018-7600: Drupal Core Remote Code Execution Vulnerability (added 3 Nov 2021)