CVE-2019-11580: Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability
- Is it exploited?
Yes. CISA added it to the Known Exploited Vulnerabilities catalog on , 884 days after the CVE record was published.
- How likely is exploitation in the next 30 days?
- 95.4%
EPSS score, percentile 99.9 of all scored records
- How severe?
- 9.8 Critical
CVSS v3.1 base score, from CISA's enrichment of the record
- What should I do?
CISA deadline . Apply updates per vendor instructions.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- 2.1.0
- before 3.0.5
- 3.1.0
- before 3.1.6
- 3.2.0
- before 3.2.8
and 4 more in the table below
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
What to do
Required action, set by CISA
Apply updates per vendor instructions.
CISA due date for this action: .
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
Linked from CISA's catalog entry
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | 2.1.0 |
| Affected | before 3.0.5 |
| Affected | 3.1.0 |
| Affected | before 3.1.6 |
| Affected | 3.2.0 |
| Affected | before 3.2.8 |
| Affected | 3.3.0 |
| Affected | before 3.3.5 |
| Affected | 3.4.0 |
| Affected | before 3.4.4 |
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
About this vulnerability
Atlassian Crowd and Crowd Data Center contain a remote code execution vulnerability resulting from a pdkinstall development plugin being incorrectly enabled in release builds.
Summary: CISA's KEV catalog, as of .
- CISA added CVE-2019-11580 to its Known Exploited Vulnerabilities (KEV) catalog on 3 Nov 2021.
- CISA marks it as known to be used in ransomware campaigns.
- The due date CISA sets for the required action is 3 May 2022.
- The CVE record was published on 3 Jun 2019, 884 days before it was added to KEV.
- The CVE record carries a CVSS v3.1 base score of 9.8 (Critical), taken from CISA's enrichment of the record.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 95.4% (percentile 99.9), as of 28 Oct 2026.
- CISA's SSVC assessment in the CVE record: exploitation active, automatable yes, technical impact total.
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.
Description
Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| Added to CISA KEV | |
| CISA due date for the required action | |
| CVE record last updated |
References
More exploited Atlassian vulnerabilities
- CVE-2026-21589: Atlassian Multiple Products Files or Directories Accessible to External Parties Vulnerability
- CVE-2021-26086: Atlassian Jira Server and Data Center Path Traversal Vulnerability
- CVE-2023-22527: Atlassian Confluence Data Center and Server Template Injection Vulnerability
- CVE-2023-22518: Atlassian Confluence Data Center and Server Improper Authorization Vulnerability
- CVE-2023-22515: Atlassian Confluence Data Center and Server Broken Access Control Vulnerability
- CVE-2022-36804: Atlassian Bitbucket Server and Data Center Command Injection Vulnerability