CVE-2021-38153: Timing Attack Vulnerability for Apache Kafka Connect and Clients
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 1 public report, the first from .
- How likely is exploitation in the next 30 days?
- 6.2%
EPSS score, percentile 93.5 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- Not scored
The CVE record carries no CVSS score.
- What should I do?
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- Apache Kafka 2.0.x through 2.0.1
- Apache Kafka 2.1.x through 2.1.1
- Apache Kafka 2.2.x through 2.2.2
- Apache Kafka 2.3.x through 2.3.1
- Apache Kafka 2.4.x through 2.4.1
- Apache Kafka 2.5.x through 2.5.1
and 3 more in the table below
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
Timing Attack Vulnerability for Apache Kafka Connect and Clients
Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (1 product)
| Status | Versions |
|---|---|
| Affected | Apache Kafka 2.0.x through 2.0.1 |
| Affected | Apache Kafka 2.1.x through 2.1.1 |
| Affected | Apache Kafka 2.2.x through 2.2.2 |
| Affected | Apache Kafka 2.3.x through 2.3.1 |
| Affected | Apache Kafka 2.4.x through 2.4.1 |
| Affected | Apache Kafka 2.5.x through 2.5.1 |
| Affected | Apache Kafka 2.6.x through 2.6.2 |
| Affected | Apache Kafka 2.7.x through 2.7.1 |
| Affected | Apache Kafka 2.8.x through 2.8.0 |
Source: CVE List, as of . About the data.
Weakness
CWE-203
- CWE-203: Observable Discrepancy
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
References
11
- kafka.apache.org
- [kafka-dev] 20211007 Re: CVE Back Port?
- [kafka-dev] 20211012 [VOTE] 2.6.3 RC0
- [kafka-users] 20211012 [VOTE] 2.6.3 RC0
- [kafka-users] 20211012 [VOTE] 2.7.2 RC0
- [kafka-dev] 20211012 [VOTE] 2.7.2 RC0
- [kafka-users] 20211026 Re: [kafka-clients] [VOTE] 2.7.2 RC0
- [kafka-dev] 20211026 Re: [kafka-clients] [VOTE] 2.7.2 RC0
- oracle.com
- oracle.com
- oracle.com
Known exploited Apache vulnerabilities
- CVE-2016-3081: Apache Struts Command Injection Vulnerability
- CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
- CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability
- CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability
- CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability