CVE-2022-21661: SQL injection in WordPress
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 24 public reports, the first from .
- How likely is exploitation in the next 30 days?
- 97.8%
EPSS score, percentile 99.9 of all scored records. A probability estimated by FIRST, not a report of exploitation.
CISA's SSVC assessment in the CVE record lists exploitation as poc.
- How severe?
- 8.0 High
CVSS v3.1 base score, given by the CNA
- What should I do?
CISA has set no required action, because the vulnerability is not in KEV.
- Which versions are affected?
Affected
- < 5.8.3
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
SQL injection in WordPress
WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (1 product)
| Status | Versions |
|---|---|
| Affected | < 5.8.3 |
Source: CVE List, as of . About the data.
Weakness
CWE-89
- CWE-89: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
References
7
Known exploited WordPress vulnerabilities
- CVE-2026-87902: WordPress Core Remote File Inclusion Vulnerability
- CVE-2026-60137: WordPress Core SQL Injection Vulnerability
- CVE-2026-63030: WordPress Core Interpretation Conflict Vulnerability
- CVE-2019-9978: WordPress Social Warfare Plugin Cross-Site Scripting (XSS) Vulnerability
- CVE-2020-11738: WordPress Snap Creek Duplicator Plugin File Download Vulnerability