CVE-2022-24112: Apache APISIX Authentication Bypass Vulnerability
- Is it exploited?
Yes. CISA added it to the Known Exploited Vulnerabilities catalog on 25 Aug 2022, 195 days after the CVE record was published.
- How likely is exploitation in the next 30 days?
- 96.1%
EPSS score, percentile 99.9 of all scored records
- How severe?
- 9.8 Critical
CVSS v3.1 base score, from CISA's enrichment of the record
- What should I do?
CISA deadline 15 Sep 2022. Apply updates per vendor instructions.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- from Apache APISIX 2.12 to before 2.12.1
- from Apache APISIX 2.10 to before 2.10.4
- 1.3
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of 28 Oct 2026; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of 28 Oct 2026; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
What to do
Required action, set by CISA
Apply updates per vendor instructions.
CISA due date for this action: 15 September 2022.
Workaround (from the CVE record)
1. explicitly configure the enabled plugins in `conf/config.yaml`, ensure `batch-requests` is disabled. (Or just comment out `batch-requests` in `conf/config-default.yaml`) Or 1. upgrade to 2.10.4 or 2.12.1.
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
Linked from CISA's catalog entry
- https://lists.apache.org/thread/lcdqywz8zy94mdysk7p3gfdgn51jmt94
- https://nvd.nist.gov/vuln/detail/CVE-2022-24112
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | from Apache APISIX 2.12 to before 2.12.1 |
| Affected | from Apache APISIX 2.10 to before 2.10.4 |
| Affected | 1.3 |
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
About this vulnerability
Apache APISIX contains an authentication bypass vulnerability that allows for remote code execution.
Summary: CISA's KEV catalog, as of 28 Oct 2026.
- CISA added CVE-2022-24112 to its Known Exploited Vulnerabilities (KEV) catalog on 25 Aug 2022.
- CISA's ransomware flag for this entry is "Unknown": no evidence of ransomware use in the catalog, which is not proof of none.
- The due date CISA sets for the required action is 15 Sep 2022.
- The CVE record was published on 11 Feb 2022, 195 days before it was added to KEV.
- The CVE record carries a CVSS v3.1 base score of 9.8 (Critical), taken from CISA's enrichment of the record.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 96.1% (percentile 99.9), as of 28 Oct 2026.
- CISA's SSVC assessment in the CVE record: exploitation active, automatable yes, technical impact total.
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of 28 Oct 2026; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of 28 Oct 2026. About the data.
Description
apisix/batch-requests plugin allows overwriting the X-REAL-IP header
An attacker can abuse the batch-requests plugin to send requests to bypass the IP restriction of Admin API. A default configuration of Apache APISIX (with default API key) is vulnerable to remote code execution. When the admin key was changed or the port of Admin API was changed to a port different from the data panel, the impact is lower. But there is still a risk to bypass the IP restriction of Apache APISIX's data panel. There is a check in the batch-requests plugin which overrides the client IP with its real remote IP. But due to a bug in the code, this check can be bypassed.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
Weakness
- CWE-290: Authentication Bypass by Spoofing
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record and the KEV entry.
Timeline
| Date | Event |
|---|---|
| 11 Feb 2022 | CVE record published |
| 25 Aug 2022 | Added to CISA KEV |
| 15 Sep 2022 | CISA due date for the required action |
| 21 Oct 2025 | CVE record last updated |
References
- lists.apache.org
- [oss-security] 20220211 CVE-2022-24112: Apache APISIX: apisix/batch-requests plugin allows overwriting the X-REAL-IP header
- packetstormsecurity.com
- packetstormsecurity.com
More exploited Apache vulnerabilities
- CVE-2016-3081: Apache Struts Command Injection Vulnerability
- CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
- CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability
- CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability
- CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability
- CVE-2024-45195: Apache OFBiz Forced Browsing Vulnerability