CVE-2023-27997: Fortinet FortiOS and FortiProxy SSL-VPN Heap-Based Buffer Overflow Vulnerability
- Is it exploited?
Yes. CISA added it to the Known Exploited Vulnerabilities catalog on , the same day the CVE record was published.
- How likely is exploitation in the next 30 days?
- 85.7%
EPSS score, percentile 99.7 of all scored records
- How severe?
- 9.2 Critical
CVSS v3.1 base score, given by the CNA
- What should I do?
CISA deadline . Apply updates per vendor instructions.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- 7.0.10
- 7.0.5
- 6.4.12
- 6.4.10
- 6.4.8
- 6.4.6
and 16 more in the table below
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
What to do
Required action, set by CISA
Apply updates per vendor instructions.
CISA due date for this action: .
Solution (from the CVE record)
Please upgrade to FortiOS-6K7K version 7.0.12 or above Please upgrade to FortiOS-6K7K version 6.4.13 or above Please upgrade to FortiOS-6K7K version 6.2.15 or above Please upgrade to FortiOS-6K7K version 6.0.17 or above Please upgrade to FortiProxy version 7.2.4 or above Please upgrade to FortiProxy version 7.0.10 or above Please upgrade to FortiOS version 7.4.0 or above Please upgrade to FortiOS version 7.2.5 or above Please upgrade to FortiOS version 7.0.12 or above Please upgrade to FortiOS version 6.4.13 or above Please upgrade to FortiOS version 6.2.14 or above Please upgrade to FortiOS version 6.0.17 or above
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
Linked from CISA's catalog entry
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | 7.0.10 |
| Affected | 7.0.5 |
| Affected | 6.4.12 |
| Affected | 6.4.10 |
| Affected | 6.4.8 |
| Affected | 6.4.6 |
| Affected | 6.4.2 |
| Affected | 6.2.9 through 6.2.13 |
| Affected | 6.2.6 through 6.2.7 |
| Affected | 6.2.4 |
| Affected | 6.0.12 through 6.0.16 |
| Affected | 6.0.10 |
Versions not listed are: unaffected.
| Status | Versions |
|---|---|
| Affected | 7.2.0 through 7.2.3 |
| Affected | 7.0.0 through 7.0.9 |
| Affected | 2.0.0 through 2.0.12 |
| Affected | 1.2.0 through 1.2.13 |
| Affected | 1.1.0 through 1.1.6 |
Versions not listed are: unaffected.
| Status | Versions |
|---|---|
| Affected | 7.2.0 through 7.2.4 |
| Affected | 7.0.0 through 7.0.11 |
| Affected | 6.4.0 through 6.4.12 |
| Affected | 6.2.0 through 6.2.13 |
| Affected | 6.0.0 through 6.0.16 |
Versions not listed are: unaffected.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
About this vulnerability
Fortinet FortiOS and FortiProxy SSL-VPN contain a heap-based buffer overflow vulnerability which can allow an unauthenticated, remote attacker to execute code or commands via specifically crafted requests.
Summary: CISA's KEV catalog, as of .
- CISA added CVE-2023-27997 to its Known Exploited Vulnerabilities (KEV) catalog on 13 Jun 2023.
- CISA marks it as known to be used in ransomware campaigns.
- The due date CISA sets for the required action is 4 Jul 2023.
- The CVE record was published on 13 Jun 2023, the same day it was added to KEV.
- The CVE record carries a CVSS v3.1 base score of 9.2 (Critical), given by its CNA.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 85.7% (percentile 99.7), as of 28 Oct 2026.
- CISA's SSVC assessment in the CVE record: exploitation active, automatable yes, technical impact total.
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.
Description
A heap-based buffer overflow vulnerability [CWE-122] in FortiOS version 7.2.4 and below, version 7.0.11 and below, version 6.4.12 and below, version 6.0.16 and below and FortiProxy version 7.2.3 and below, version 7.0.9 and below, version 2.0.12 and below, version 1.2 all versions, version 1.1 all versions SSL-VPN may allow a remote attacker to execute arbitrary code or commands via specifically crafted requests.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
Weakness
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record and the KEV entry.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| Added to CISA KEV | |
| CISA due date for the required action | |
| CVE record last updated |
References
More exploited Fortinet vulnerabilities
- CVE-2025-61624: Fortinet Multiple Products Path Traversal Vulnerability
- CVE-2026-104286: Fortinet FortiMail Path Traversal Vulnerability
- CVE-2025-25249: Fortinet Multiple Products Heap-based Buffer Overflow Vulnerability
- CVE-2025-68686: Fortinet FortiOS Exposure of Sensitive Information to an Unauthorized Actor Vulnerability
- CVE-2026-25089: Fortinet FortiSandbox OS Command Injection Vulnerability
- CVE-2026-39808: Fortinet FortiSandbox OS Command Injection Vulnerability