VulnTideExploited vulnerabilities, by vendor. Data as of .
Not in CISA KEVReported exploited: VulnCheck KEV since Published CVSS 6.6 mediumEPSS 35.5% probability of exploitation in 30 days
Apache

CVE-2023-37941: Apache Superset: Metadata db write access can lead to remote code execution

Is it exploited?

Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .

VulnCheck KEV lists it since . It cites 1 public report, the first from .

How likely is exploitation in the next 30 days?
35.5%

EPSS score, percentile 98.4 of all scored records. A probability estimated by FIRST, not a report of exploitation.

How severe?
6.6 Medium

CVSS v3.1 base score, given by the CNA

What should I do?

CISA has set no required action, because the vulnerability is not in KEV.

Advisories and patches (1)

Which versions are affected?

Affected

  • 1.5.0 through 2.1.0

Versions by product

Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.

Description

Apache Superset: Metadata db write access can lead to remote code execution

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

Source: CVE List, as of . About the data.

What to do

Advisories and patches

This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.

Affected products and versions

Versions by product, as listed in the CVE record (1 product)
Apache Software Foundation Apache Superset
StatusVersions
Affected1.5.0 through 2.1.0

Versions not listed are: unaffected.

Source: CVE List, as of . About the data.

Weakness

CWE-502
  • CWE-502: Deserialization of Untrusted Data

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.

Timeline

DateEvent
CVE record published
CVE record last updated

References

1

Known exploited Apache vulnerabilities

  • CVE-2016-3081: Apache Struts Command Injection Vulnerability (added )
  • CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability (added )
  • CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability (added )
  • CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability (added )
  • CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability (added )