CVE-2024-21754: A use of password hash with insufficient computational effort vulnerability [CWE-916] affecting FortiOS version 7.4.3…
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 1 public report, the first from .
- How likely is exploitation in the next 30 days?
- 3.5%
EPSS score, percentile 89 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 1.7 Low
CVSS v3.1 base score, given by the CNA
- What should I do?
Please upgrade to FortiProxy version 7.4.3 or above Please upgrade to FortiOS version 7.4.4 or aboveSolution from the CVE record.
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- 7.4.0 through 7.4.2
- 7.2.0 through 7.2.10
- 7.0.0 through 7.0.17
- 2.0.0 through 2.0.14
- 7.4.0 through 7.4.3
- 7.2.0 through 7.2.8
and 2 more in the table below
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
A use of password hash with insufficient computational effort vulnerability [CWE-916] affecting FortiOS version 7.4.3 and below, 7.2 all versions, 7.0 all versions, 6.4 all versions and FortiProxy version 7.4.2 and below, 7.2 all versions, 7.0 all versions, 2.0 all versions may allow a privileged attacker with super-admin profile and CLI access to decrypting the backup file.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (2 products)
| Status | Versions |
|---|---|
| Affected | 7.4.0 through 7.4.2 |
| Affected | 7.2.0 through 7.2.10 |
| Affected | 7.0.0 through 7.0.17 |
| Affected | 2.0.0 through 2.0.14 |
Versions not listed are: unaffected.
| Status | Versions |
|---|---|
| Affected | 7.4.0 through 7.4.3 |
| Affected | 7.2.0 through 7.2.8 |
| Affected | 7.0.0 through 7.0.15 |
| Affected | 6.4.0 through 6.4.15 |
Versions not listed are: unaffected.
Source: CVE List, as of . About the data.
Weakness
CWE-916
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
Known exploited Fortinet vulnerabilities
- CVE-2025-61624: Fortinet Multiple Products Path Traversal Vulnerability
- CVE-2026-104286: Fortinet FortiMail Path Traversal Vulnerability
- CVE-2025-25249: Fortinet Multiple Products Heap-based Buffer Overflow Vulnerability
- CVE-2025-68686: Fortinet FortiOS Exposure of Sensitive Information to an Unauthorized Actor Vulnerability
- CVE-2026-25089: Fortinet FortiSandbox OS Command Injection Vulnerability