CVE-2024-23109: An improper neutralization of special elements used in an os command ('os command injection') vulnerability in Fortin…
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 7 public reports, the first from .
- How likely is exploitation in the next 30 days?
- 3.3%
EPSS score, percentile 88.5 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 9.7 Critical
CVSS v3.1 base score, given by the CNA
- What should I do?
Please upgrade to FortiSIEM version 7.1.2 or above Please upgrade to FortiSIEM version 7.0.3 or above Please upgrade to FortiSIEM version 6.7.9 or above Please upgrade … Full textSolution from the CVE record.
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- 7.1.1
- 7.0.0 through 7.0.2
- 6.7.0 through 6.7.8
- 6.6.0 through 6.6.3
- 6.5.0 through 6.5.2
- 6.4.0 through 6.4.3
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
An improper neutralization of special elements used in an os command ('os command injection') vulnerability in Fortinet allows attacker to execute unauthorized code or commands via via crafted API requests.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
Solution (from the CVE record)
Please upgrade to FortiSIEM version 7.1.2 or above Please upgrade to FortiSIEM version 7.0.3 or above Please upgrade to FortiSIEM version 6.7.9 or above Please upgrade to FortiSIEM version 6.6.4 or above Please upgrade to FortiSIEM version 6.5.3 or above Please upgrade to FortiSIEM version 6.4.4 or above Please upgrade to upcoming FortiSIEM version 7.2.0 or above
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (1 product)
| Status | Versions |
|---|---|
| Affected | 7.1.1 |
| Affected | 7.0.0 through 7.0.2 |
| Affected | 6.7.0 through 6.7.8 |
| Affected | 6.6.0 through 6.6.3 |
| Affected | 6.5.0 through 6.5.2 |
| Affected | 6.4.0 through 6.4.3 |
Versions not listed are: unaffected.
Source: CVE List, as of . About the data.
Weakness
CWE-78
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
References
1
Known exploited Fortinet vulnerabilities
- CVE-2025-61624: Fortinet Multiple Products Path Traversal Vulnerability
- CVE-2026-104286: Fortinet FortiMail Path Traversal Vulnerability
- CVE-2025-25249: Fortinet Multiple Products Heap-based Buffer Overflow Vulnerability
- CVE-2025-68686: Fortinet FortiOS Exposure of Sensitive Information to an Unauthorized Actor Vulnerability
- CVE-2026-25089: Fortinet FortiSandbox OS Command Injection Vulnerability