CVE-2024-38856: Apache OFBiz Incorrect Authorization Vulnerability
- Is it exploited?
Yes. CISA added it to the Known Exploited Vulnerabilities catalog on 27 Aug 2024, 22 days after the CVE record was published.
- How likely is exploitation in the next 30 days?
- 99.4%
EPSS score, percentile 99.9 of all scored records
- How severe?
- 8.1 High
CVSS v3.1 base score, from CISA's enrichment of the record
- What should I do?
Required action (CISA), due 17 Sep 2024: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
- Which versions are affected?
Affected: 18.12.14 and earlier
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of 28 Oct 2026; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of 28 Oct 2026; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
What to do
Required action, set by CISA
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
CISA due date for this action: 17 September 2024.
Advisories and patches
Linked from CISA's catalog entry
- https://lists.apache.org/thread/olxxjk6b13sl3wh9cmp0k2dscvp24l7w
- https://nvd.nist.gov/vuln/detail/CVE-2024-38856
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | 18.12.14 and earlier |
Versions not listed are: unaffected.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
About this vulnerability
Apache OFBiz contains an incorrect authorization vulnerability that could allow remote code execution via a Groovy payload in the context of the OFBiz user process by an unauthenticated attacker.
Summary: CISA's KEV catalog, as of 28 Oct 2026.
- CISA added CVE-2024-38856 to its Known Exploited Vulnerabilities (KEV) catalog on 27 Aug 2024.
- CISA's ransomware flag for this entry is "Unknown": no evidence of ransomware use in the catalog, which is not proof of none.
- The due date CISA sets for the required action is 17 Sep 2024.
- The CVE record was published on 5 Aug 2024, 22 days before it was added to KEV.
- The CVE record carries a CVSS v3.1 base score of 8.1 (High), taken from CISA's enrichment of the record.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 99.4% (percentile 99.9), as of 28 Oct 2026.
- CISA's SSVC assessment in the CVE record: exploitation active, automatable yes, technical impact total.
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of 28 Oct 2026; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of 28 Oct 2026. About the data.
Description
Apache OFBiz: Unauthenticated endpoint could allow execution of screen rendering code
Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
Weakness
- CWE-863: Incorrect Authorization
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record and the KEV entry.
Timeline
| Date | Event |
|---|---|
| 5 Aug 2024 | CVE record published |
| 27 Aug 2024 | Added to CISA KEV |
| 17 Sep 2024 | CISA due date for the required action |
| 21 Oct 2025 | CVE record last updated |
References
More exploited Apache vulnerabilities
- CVE-2016-3081: Apache Struts Command Injection Vulnerability
- CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
- CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability
- CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability
- CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability
- CVE-2024-45195: Apache OFBiz Forced Browsing Vulnerability