CVE-2024-52301: Laravel allows environment manipulation via query string
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 1 public report, the first from .
- How likely is exploitation in the next 30 days?
- 44.8%
EPSS score, percentile 98.8 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 8.7 High
CVSS v4.0 base score, given by the CNA
- What should I do?
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- < 6.20.45
- >= 7.0.0, < 7.30.7
- >= 8.0.0, < 8.83.28
- >= 9.0.0, < 9.52.17
- >= 10.0.0, < 10.48.23
- >= 11.0.0, < 11.31.0
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
Laravel allows environment manipulation via query string
Laravel is a web application framework. When the register_argc_argv php directive is set to on , and users call any URL with a special crafted query string, they are able to change the environment used by the framework when handling the request. The vulnerability fixed in 6.20.45, 7.30.7, 8.83.28, 9.52.17, 10.48.23, and 11.31.0. The framework now ignores argv values for environment detection on non-cli SAPIs.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (1 product)
| Status | Versions |
|---|---|
| Affected | < 6.20.45 |
| Affected | >= 7.0.0, < 7.30.7 |
| Affected | >= 8.0.0, < 8.83.28 |
| Affected | >= 9.0.0, < 9.52.17 |
| Affected | >= 10.0.0, < 10.48.23 |
| Affected | >= 11.0.0, < 11.31.0 |
Source: CVE List, as of . About the data.
Weakness
CWE-88
- CWE-88: Improper Neutralization of Argument Delimiters in a Command ('Argument Injection')
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
Known exploited Laravel vulnerabilities
- CVE-2025-54068: Laravel Livewire Code Injection Vulnerability
- CVE-2018-15133: Laravel Deserialization of Untrusted Data Vulnerability
- CVE-2021-3129: Laravel Ignition File Upload Vulnerability