VulnTideExploited vulnerabilities, by vendor. Data as of .
Known exploitedIn CISA's KEV catalog since Ransomware use: unknown
Craft CMS Craft CMS

CVE-2024-56145: Craft CMS Code Injection Vulnerability

Is it exploited?

Yes. CISA added it to the Known Exploited Vulnerabilities catalog on , 166 days after the CVE record was published.

How likely is exploitation in the next 30 days?
97.4%

EPSS score, percentile 99.9 of all scored records

How severe?
9.3 Critical

CVSS v4.0 base score, given by the CNA

What should I do?

CISA deadline . Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

The CVE record links no vendor advisory, patch or mitigation.

Which versions are affected?

Affected

  • >= 4.0.0-RC1, < 4.13.2
  • >= 5.0.0-RC1, < 5.5.2
  • >= 3.0.0, < 3.9.14

Versions by product

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

What to do

Required action, set by CISA

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

CISA due date for this action: .

Advisories and patches

The CVE record links no vendor advisory, patch or mitigation.

Linked from CISA's catalog entry

Affected products and versions

As listed in the CVE record.

craftcms cms
StatusVersions
Affected>= 4.0.0-RC1, < 4.13.2
Affected>= 5.0.0-RC1, < 5.5.2
Affected>= 3.0.0, < 3.9.14

Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

About this vulnerability

Craft CMS contains a code injection vulnerability. Users with affected versions are vulnerable to remote code execution if their php.ini configuration has `register_argc_argv` enabled.

Summary: CISA's KEV catalog, as of .

  • CISA added CVE-2024-56145 to its Known Exploited Vulnerabilities (KEV) catalog on 2 Jun 2025.
  • CISA's ransomware flag for this entry is "Unknown": no evidence of ransomware use in the catalog, which is not proof of none.
  • The due date CISA sets for the required action is 23 Jun 2025.
  • The CVE record was published on 18 Dec 2024, 166 days before it was added to KEV.
  • The CVE record carries a CVSS v4.0 base score of 9.3 (Critical), given by its CNA.
  • FIRST's EPSS model puts the probability of exploitation in the next 30 days at 97.4% (percentile 99.9), as of 28 Oct 2026.
  • CISA's SSVC assessment in the CVE record: exploitation active, automatable yes, technical impact total.

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.

Description

RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.

Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

Weakness

  • CWE-94: Improper Control of Generation of Code ('Code Injection')

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record and the KEV entry.

Timeline

DateEvent
CVE record published
Added to CISA KEV
CISA due date for the required action
CVE record last updated

References

More exploited Craft CMS vulnerabilities

  • CVE-2025-32432: Craft CMS Code Injection Vulnerability (added )
  • CVE-2025-35939: Craft CMS External Control of Assumed-Immutable Web Parameter Vulnerability (added )
  • CVE-2025-23209: Craft CMS Code Injection Vulnerability (added )