CVE-2025-25256: An improper neutralization of special elements used in an OS command ('OS Command Injection') vulnerability [CWE-78]…
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 4 public reports, the first from .
- How likely is exploitation in the next 30 days?
- 65.3%
EPSS score, percentile 99.3 of all scored records. A probability estimated by FIRST, not a report of exploitation.
CISA's SSVC assessment in the CVE record lists exploitation as poc.
- How severe?
- 9.8 Critical
CVSS v3.1 base score, given by the CNA
- What should I do?
Upgrade to FortiSIEM version 7.4.0 or above Upgrade to FortiSIEM version 7.3.2 or above Upgrade to FortiSIEM version 7.2.6 or above Upgrade to FortiSIEM version 7.1.8 or … Full textSolution from the CVE record.
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- 7.3.0 through 7.3.1
- 7.2.0 through 7.2.5
- 7.1.0 through 7.1.7
- 7.0.0 through 7.0.3
- 6.7.0 through 6.7.9
- 6.6.0 through 6.6.5
and 6 more in the table below
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
An improper neutralization of special elements used in an OS command ('OS Command Injection') vulnerability [CWE-78] vulnerability in Fortinet FortiSIEM 7.3.0 through 7.3.1, FortiSIEM 7.2.0 through 7.2.5, FortiSIEM 7.1.0 through 7.1.7, FortiSIEM 7.0.0 through 7.0.3, FortiSIEM 6.7.0 through 6.7.9, FortiSIEM 6.6 all versions, FortiSIEM 6.5 all versions, FortiSIEM 6.4 all versions, FortiSIEM 6.3 all versions, FortiSIEM 6.2 all versions, FortiSIEM 6.1 all versions, FortiSIEM 5.4 all versions, FortiSIEM 5.3 all versions, FortiSIEM 5.2 all versions, FortiSIEM 5.1 all versions, FortiSIEM 5.0 all versions, FortiSIEM 4.10 all versions, FortiSIEM 4.9 all versions, FortiSIEM 4.7 all versions allows an unauthenticated attacker to execute unauthorized code or commands via crafted CLI requests.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
Solution (from the CVE record)
Upgrade to FortiSIEM version 7.4.0 or above Upgrade to FortiSIEM version 7.3.2 or above Upgrade to FortiSIEM version 7.2.6 or above Upgrade to FortiSIEM version 7.1.8 or above Upgrade to FortiSIEM version 7.0.4 or above Upgrade to FortiSIEM version 6.7.10 or above
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (1 product)
| Status | Versions |
|---|---|
| Affected | 7.3.0 through 7.3.1 |
| Affected | 7.2.0 through 7.2.5 |
| Affected | 7.1.0 through 7.1.7 |
| Affected | 7.0.0 through 7.0.3 |
| Affected | 6.7.0 through 6.7.9 |
| Affected | 6.6.0 through 6.6.5 |
| Affected | 6.5.0 through 6.5.3 |
| Affected | 6.4.0 through 6.4.4 |
| Affected | 6.3.0 through 6.3.3 |
| Affected | 6.2.0 through 6.2.1 |
| Affected | 6.1.0 through 6.1.2 |
| Affected | 5.4.0 |
Versions not listed are: unaffected.
And 8 more version entries in the CVE record.
Source: CVE List, as of . About the data.
Weakness
CWE-78
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
Known exploited Fortinet vulnerabilities
- CVE-2025-61624: Fortinet Multiple Products Path Traversal Vulnerability
- CVE-2026-104286: Fortinet FortiMail Path Traversal Vulnerability
- CVE-2025-25249: Fortinet Multiple Products Heap-based Buffer Overflow Vulnerability
- CVE-2025-68686: Fortinet FortiOS Exposure of Sensitive Information to an Unauthorized Actor Vulnerability
- CVE-2026-25089: Fortinet FortiSandbox OS Command Injection Vulnerability