CVE-2025-55190: Argo CD: Project API Token Exposes Repository Credentials
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 94 public reports, the first from .
- How likely is exploitation in the next 30 days?
- 5.7%
EPSS score, percentile 93 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 10.0 Critical
CVSS v3.1 base score, given by the CNA
- What should I do?
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- >= 2.13.0, < 2.13.9
- >= 2.14.0, < 2.14.16
- >= 3.0.0, < 3.0.14
- >= 3.1.0-rc1, < 3.1.2
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
Argo CD: Project API Token Exposes Repository Credentials
Argo CD is a declarative, GitOps continuous delivery tool for Kubernetes. In versions 2.13.0 through 2.13.8, 2.14.0 through 2.14.15, 3.0.0 through 3.0.12 and 3.1.0-rc1 through 3.1.1, API tokens with project-level permissions are able to retrieve sensitive repository credentials (usernames, passwords) through the project details API endpoint, even when the token only has standard application management permissions and no explicit access to secrets. This vulnerability does not only affect project-level permissions. Any token with project get permissions is also vulnerable, including global permissions such as: `p, role/user, projects, get, *, allow`. This issue is fixed in versions 2.13.9, 2.14.16, 3.0.14 and 3.1.2.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (1 product)
| Status | Versions |
|---|---|
| Affected | >= 2.13.0, < 2.13.9 |
| Affected | >= 2.14.0, < 2.14.16 |
| Affected | >= 3.0.0, < 3.0.14 |
| Affected | >= 3.1.0-rc1, < 3.1.2 |
Source: CVE List, as of . About the data.
Weakness
CWE-200
- CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |