VulnTideExploited vulnerabilities, by vendor. Data as of .
Known exploitedIn CISA's KEV catalog since Ransomware use: unknown
OSGeo GeoServer

CVE-2025-58360: OSGeo GeoServer Improper Restriction of XML External Entity Reference Vulnerability

Is it exploited?

Yes. CISA added it to the Known Exploited Vulnerabilities catalog on , 16 days after the CVE record was published.

How likely is exploitation in the next 30 days?
61.2%

EPSS score, percentile 99.2 of all scored records

How severe?
8.2 High

CVSS v3.1 base score, given by the CNA

What should I do?

CISA deadline . Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

The CVE record links no vendor advisory, patch or mitigation.

Which versions are affected?

Affected

  • >= 2.26.0, < 2.26.2
  • < 2.25.6

Versions by product

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

What to do

Required action, set by CISA

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

CISA due date for this action: .

Advisories and patches

The CVE record links no vendor advisory, patch or mitigation.

Linked from CISA's catalog entry

Affected products and versions

As listed in the CVE record.

geoserver geoserver
StatusVersions
Affected>= 2.26.0, < 2.26.2
Affected< 2.25.6

Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

About this vulnerability

OSGeo GeoServer contains an improper restriction of XML external entity reference vulnerability that occurs when the application accepts XML input through a specific endpoint /geoserver/wms operation GetMap and could allow an attacker to define external entities within the XML request.

Summary: CISA's KEV catalog, as of .

  • CISA added CVE-2025-58360 to its Known Exploited Vulnerabilities (KEV) catalog on 11 Dec 2025.
  • CISA's ransomware flag for this entry is "Unknown": no evidence of ransomware use in the catalog, which is not proof of none.
  • The due date CISA sets for the required action is 1 Jan 2026.
  • The CVE record was published on 25 Nov 2025, 16 days before it was added to KEV.
  • The CVE record carries a CVSS v3.1 base score of 8.2 (High), given by its CNA.
  • FIRST's EPSS model puts the probability of exploitation in the next 30 days at 61.2% (percentile 99.2), as of 28 Oct 2026.
  • CISA's SSVC assessment in the CVE record: exploitation active, automatable yes, technical impact partial.

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.

Description

GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

Weakness

  • CWE-611: Improper Restriction of XML External Entity Reference

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record and the KEV entry.

Timeline

DateEvent
CVE record published
Added to CISA KEV
CISA due date for the required action
CVE record last updated

References

More exploited OSGeo vulnerabilities

  • CVE-2024-36401: OSGeo GeoServer GeoTools Eval Injection Vulnerability (added )
  • CVE-2022-24816: OSGeo GeoServer JAI-EXT Code Injection Vulnerability (added )