VulnTideExploited vulnerabilities, by vendor. Data as of .
Not in CISA KEVReported exploited: VulnCheck KEV since Published CVSS 8.1 highEPSS 50.4% probability of exploitation in 30 days
Apache

CVE-2025-68493: Apache Struts, Apache Struts: XXE vulnerability in outdated XWork component

Is it exploited?

Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .

VulnCheck KEV lists it since . It cites 13 public reports, the first from .

How likely is exploitation in the next 30 days?
50.4%

Up from 45.8% on .

EPSS score, percentile 98.9 of all scored records. A probability estimated by FIRST, not a report of exploitation.

How severe?
8.1 High

CVSS v3.1 base score, from CISA's enrichment of the record

What should I do?

CISA has set no required action, because the vulnerability is not in KEV.

Advisories and patches (1)

Which versions are affected?

Affected

  • from 2.0.0 to before 2.2.1
  • 2.2.1 through 6.1.0

Versions by product

Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.

Description

Apache Struts, Apache Struts: XXE vulnerability in outdated XWork component

Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.

Source: CVE List, as of . About the data.

What to do

Advisories and patches

This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.

Affected products and versions

Versions by product, as listed in the CVE record (2 products)
Apache Software Foundation Apache Struts
StatusVersions
Affectedfrom 2.0.0 to before 2.2.1

Versions not listed are: unaffected.

Apache Software Foundation Apache Struts
StatusVersions
Affected2.2.1 through 6.1.0

Versions not listed are: unaffected.

Source: CVE List, as of . About the data.

Weakness

CWE-611
  • CWE-611: Improper Restriction of XML External Entity Reference

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.

Timeline

DateEvent
CVE record published
CVE record last updated

Known exploited Apache vulnerabilities

  • CVE-2016-3081: Apache Struts Command Injection Vulnerability (added )
  • CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability (added )
  • CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability (added )
  • CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability (added )
  • CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability (added )