VulnTideExploited vulnerabilities, by vendor. Data as of .
Not in CISA KEVPublished CVSS 9.4 criticalEPSS 1.8% probability of exploitation in 30 days
zosmaai

CVE-2026-102911: zosmaai pi-llm-wiki wiki_capture_source MCP tool index.ts os command injection

Is it exploited?

Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.

How likely is exploitation in the next 30 days?
1.8%

EPSS score, percentile 78.2 of all scored records. A probability estimated by FIRST, not a report of exploitation.

CISA's SSVC assessment in the CVE record lists exploitation as poc.

How severe?
9.4 Critical

CVSS v4.0 base score, given by the CNA

What should I do?

CISA has set no required action, because the vulnerability is not in KEV.

Advisories and patches (3)

Which versions are affected?

Affected

  • 0.11.0
  • 0.11.1
  • 0.11.2
  • 0.11.3
  • 0.11.4
  • 0.11.5

and 2 more in the table below

Unaffected 0.11.8

Versions by product

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-29_0000Z, as of . About the data.

What to do

Advisories and patches

Affected products and versions

As listed in the CVE record.

zosmaai pi-llm-wiki
StatusVersions
Affected0.11.0
Affected0.11.1
Affected0.11.2
Affected0.11.3
Affected0.11.4
Affected0.11.5
Affected0.11.6
Affected0.11.7
Unaffected0.11.8

Versions the record lists as unaffected: 0.11.8.

Source: CVE List V5 (CVE Program), cve_2026-10-29_0000Z, as of . About the data.

About this vulnerability

A flaw has been found in zosmaai pi-llm-wiki up to 0.11.7. Affected is an unknown function of the file mcp/index.ts of the component wiki_capture_source MCP tool. Executing a manipulation of the argument url can lead to os command injection. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 0.11.8 is able to address this issue. This patch is…

Summary: CVE record, as of .

  • CISA has not added CVE-2026-102911 to its Known Exploited Vulnerabilities (KEV) catalog, as of 28 Oct 2026.
  • The CVE record was published on 30 Sep 2026.
  • The CVE record carries a CVSS v4.0 base score of 9.4 (Critical), given by its CNA.
  • FIRST's EPSS model puts the probability of exploitation in the next 30 days at 1.8% (percentile 78.2), as of 29 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
  • CISA's SSVC assessment in the CVE record: exploitation poc, automatable no, technical impact total.

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-29_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.

Description

zosmaai pi-llm-wiki wiki_capture_source MCP tool index.ts os command injection

A flaw has been found in zosmaai pi-llm-wiki up to 0.11.7. Affected is an unknown function of the file mcp/index.ts of the component wiki_capture_source MCP tool. Executing a manipulation of the argument url can lead to os command injection. The attack can be executed remotely. The exploit has been published and may be used. Upgrading to version 0.11.8 is able to address this issue. This patch is called 360867034e79175b45c8e04a98e4ca712bbaca35. Upgrading the affected component is advised.

Source: CVE List V5 (CVE Program), cve_2026-10-29_0000Z, as of . About the data.

Weakness

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.

Timeline

DateEvent
CVE record published

References