VulnTideExploited vulnerabilities, by vendor. Data as of .
Not in CISA KEVPublished CVSS 5.3 mediumEPSS 0.8% probability of exploitation in 30 daysFound by AI: Anthropic (Claude)
Apache

CVE-2026-105244: Apache log4net: RemoteSyslogAppender silently deletes non-ASCII content

Is it exploited?

Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.

How likely is exploitation in the next 30 days?
0.8%

EPSS score, percentile 57.3 of all scored records. A probability estimated by FIRST, not a report of exploitation.

How severe?
5.3 Medium

CVSS v3.1 base score, given by the CNA

What should I do?

CISA has set no required action, because the vulnerability is not in KEV.

Advisories and patches (3)

Which versions are affected?

Affected

  • from 1.2.12 to before 3.5.0

Versions by product

Source: CISA KEV 2026.10.29, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.

What to do

Advisories and patches

This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.

Affected products and versions

As listed in the CVE record.

Apache Software Foundation Apache log4net
StatusVersions
Affectedfrom 1.2.12 to before 3.5.0

Versions not listed are: unaffected.

Apache Software Foundation Apache log4net
StatusVersions
Affectedfrom 56a2e146e21f to before 77717061b20d

Versions not listed are: unaffected.

Source: CVE List, as of . About the data.

About this vulnerability

Improper Encoding or Escaping of Output vulnerability in the RemoteSyslogAppender of Apache log4net. Every character outside visible ASCII and space was removed from the record instead of being escaped, so non-ASCII text and control characters such as tabs disappeared without notice. A party whose data reaches a log message could make a distinct value look identical in the record, for example a…

Summary: CVE record, as of .

  • CISA has not added CVE-2026-105244 to its Known Exploited Vulnerabilities (KEV) catalog, as of 29 Oct 2026.
  • The CVE record was published on 6 Oct 2026.
  • The CVE record carries a CVSS v3.1 base score of 5.3 (Medium), given by its CNA.
  • FIRST's EPSS model puts the probability of exploitation in the next 30 days at 0.8% (percentile 57.3), as of 29 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
  • CISA's SSVC assessment in the CVE record: exploitation none, automatable yes, technical impact partial.
  • The credits in the CVE record name Anthropic (Claude) as finder.

Source: CISA KEV 2026.10.29, as of ; CVE List, as of ; FIRST EPSS, as of . About the data.

Description

Apache log4net: RemoteSyslogAppender silently deletes non-ASCII content

Improper Encoding or Escaping of Output vulnerability in the RemoteSyslogAppender of Apache log4net. Every character outside visible ASCII and space was removed from the record instead of being escaped, so non-ASCII text and control characters such as tabs disappeared without notice. A party whose data reaches a log message could make a distinct value look identical in the record, for example a user name holding a zero-width space logged as admin. Only applications that use RemoteSyslogAppender are affected. This issue affects Apache log4net: from 1.2.12 before 3.5.0. Users are recommended to upgrade to version 3.5.0, which fixes the issue.

Source: CVE List, as of . About the data.

Weakness

CWE-116
  • CWE-116: Improper Encoding or Escaping of Output

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.

Timeline

DateEvent
CVE record published
CVE record last updated

Known exploited Apache vulnerabilities

  • CVE-2016-3081: Apache Struts Command Injection Vulnerability (added )
  • CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability (added )
  • CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability (added )
  • CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability (added )
  • CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability (added )