CVE-2026-35029: LiteLLM affected by privilege escalation via unrestricted proxy configuration endpoint
- Is it exploited?
Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.
- How likely is exploitation in the next 30 days?
- 38.6%
Up from 4% on .
EPSS score, percentile 98.6 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 8.7 High
CVSS v4.0 base score, given by the CNA
- What should I do?
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- < 1.83.0
Source: CISA KEV 2026.10.29, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | < 1.83.0 |
Source: CVE List, as of . About the data.
About this vulnerability
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python c…
Summary: CVE record, as of .
- CISA has not added CVE-2026-35029 to its Known Exploited Vulnerabilities (KEV) catalog, as of 29 Oct 2026.
- The CVE record was published on 6 Apr 2026.
- The CVE record carries a CVSS v4.0 base score of 8.7 (High), given by its CNA.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 38.6% (percentile 98.6), as of 29 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
- CISA's SSVC assessment in the CVE record: exploitation none, automatable no, technical impact total.
Source: CISA KEV 2026.10.29, as of ; CVE List, as of ; FIRST EPSS, as of . About the data.
Description
LiteLLM affected by privilege escalation via unrestricted proxy configuration endpoint
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.
Source: CVE List, as of . About the data.
Weakness
CWE-863
- CWE-863: Incorrect Authorization
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
Known exploited BerriAI vulnerabilities
- CVE-2026-59822: BerriAI LiteLLM Improper Authentication Vulnerability
- CVE-2026-42271: BerriAI LiteLLM Command Injection Vulnerability
- CVE-2026-42208: BerriAI LiteLLM SQL Injection Vulnerability