CVE-2026-39365: Vite has a Path Traversal in Optimized Deps `.map` Handling
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . VulnCheck's own honeypots also recorded exploitation attempts.
- How likely is exploitation in the next 30 days?
- 0.9%
Down from 1% on .
EPSS score, percentile 60.1 of all scored records. A probability estimated by FIRST, not a report of exploitation.
CISA's SSVC assessment in the CVE record lists exploitation as poc.
- How severe?
- 6.3 Medium
CVSS v4.0 base score, given by the CNA
- What should I do?
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- >= 8.0.0, < 8.0.5
- >= 7.0.0, < 7.3.2
- >= 6.0.0, < 6.4.2
- < 0.1.16
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
Vite has a Path Traversal in Optimized Deps `.map` Handling
Vite is a frontend tooling framework for JavaScript. From 6.0.0 to before 6.4.2, 7.3.2, and 8.0.5, the dev server’s handling of .map requests for optimized dependencies resolves file paths and calls readFile without restricting ../ segments in the URL. As a result, it is possible to bypass the server.fs.strict allow list and retrieve .map files located outside the project root, provided they can be parsed as valid source map JSON. This vulnerability is fixed in 6.4.2, 7.3.2, and 8.0.5.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (2 products)
| Status | Versions |
|---|---|
| Affected | >= 8.0.0, < 8.0.5 |
| Affected | >= 7.0.0, < 7.3.2 |
| Affected | >= 6.0.0, < 6.4.2 |
| Status | Versions |
|---|---|
| Affected | < 0.1.16 |
Source: CVE List, as of . About the data.
Weakness
CWE-22
- CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |