VulnTideExploited vulnerabilities, by vendor. Data as of .
Not in CISA KEVPublished EPSS 35.5% probability of exploitation in 30 days
vercel

CVE-2026-44578: Next.js: Server-side request forgery in applications using WebSocket upgrades

Is it exploited?

Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.

How likely is exploitation in the next 30 days?
35.5%

EPSS score, percentile 98.4 of all scored records. A probability estimated by FIRST, not a report of exploitation.

How severe?
8.6 High

CVSS v3.1 base score, given by the CNA

What should I do?

CISA has set no required action, because the vulnerability is not in KEV.

The CVE record links no vendor advisory, patch or mitigation.

Which versions are affected?

Affected

  • >= 16.0.0, < 16.2.5
  • >= 13.4.13, < 15.5.16

Versions by product

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

What to do

Advisories and patches

The CVE record links no vendor advisory, patch or mitigation.

Affected products and versions

As listed in the CVE record.

vercel next.js
StatusVersions
Affected>= 16.0.0, < 16.2.5
Affected>= 13.4.13, < 15.5.16

Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

About this vulnerability

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services…

Summary: CVE record, as of .

  • CISA has not added CVE-2026-44578 to its Known Exploited Vulnerabilities (KEV) catalog, as of 28 Oct 2026.
  • The CVE record was published on 13 May 2026.
  • The CVE record carries a CVSS v3.1 base score of 8.6 (High), given by its CNA.
  • FIRST's EPSS model puts the probability of exploitation in the next 30 days at 35.5% (percentile 98.4), as of 28 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
  • CISA's SSVC assessment in the CVE record: exploitation none, automatable yes, technical impact partial.

Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.

Description

Next.js: Server-side request forgery in applications using WebSocket upgrades

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.

Weakness

  • CWE-918: Server-Side Request Forgery (SSRF)

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.

Timeline

DateEvent
CVE record published
CVE record last updated

References