CVE-2026-59821: LiteLLM: Custom Code Guardrails production endpoints bypass code safety checks
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 1 public report, the first from .
- How likely is exploitation in the next 30 days?
- 0.9%
EPSS score, percentile 59.7 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 2.1 Low
CVSS v4.0 base score, given by the CNA
- What should I do?
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- < 1.82.0-stable
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
LiteLLM: Custom Code Guardrails production endpoints bypass code safety checks
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.82.0-stable, LiteLLM's Custom Code Guardrails production create and update paths did not apply the same sandboxing and validation used by the test endpoint, allowing a privileged user with access to create or update guardrails to submit custom Python code that executed in the LiteLLM proxy environment and could expose secrets available to the process. This issue is fixed in version 1.82.0-stable.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (1 product)
| Status | Versions |
|---|---|
| Affected | < 1.82.0-stable |
Source: CVE List, as of . About the data.
Weakness
CWE-94
- CWE-94: Improper Control of Generation of Code ('Code Injection')
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
References
3
Known exploited BerriAI vulnerabilities
- CVE-2026-59822: BerriAI LiteLLM Improper Authentication Vulnerability
- CVE-2026-42271: BerriAI LiteLLM Command Injection Vulnerability
- CVE-2026-42208: BerriAI LiteLLM SQL Injection Vulnerability