CVE-2026-66858: Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: skip() does not apply the recursion limit (Python accelerator, PHP, Perl, Lua, Smalltalk, OCaml)
- Is it exploited?
Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.
- How likely is exploitation in the next 30 days?
- 0.3%
EPSS score, percentile 23.4 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 8.7 High
CVSS v4.0 base score, given by the CNA
- What should I do?
CISA has set no required action, because the vulnerability is not in KEV.
- Which versions are affected?
Affected
- before 0.25.0
- before 0.25.0
- before 0.25.0
- before 0.25.0
- before 0.25.0
- before 0.25.0
Source: CISA KEV 2026.10.29, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
What to do
Advisories and patches
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | before 0.25.0 |
Versions not listed are: unaffected.
| Status | Versions |
|---|---|
| Affected | before 0.25.0 |
Versions not listed are: unaffected.
| Status | Versions |
|---|---|
| Affected | before 0.25.0 |
Versions not listed are: unaffected.
| Status | Versions |
|---|---|
| Affected | before 0.25.0 |
Versions not listed are: unaffected.
| Status | Versions |
|---|---|
| Affected | before 0.25.0 |
Versions not listed are: unaffected.
| Status | Versions |
|---|---|
| Affected | before 0.25.0 |
Versions not listed are: unaffected.
Source: CVE List, as of . About the data.
About this vulnerability
The protocol skip routine in several Apache Thrift bindings did not apply the binding's recursion limit, so a message that nests unknown fields deeply enough can exhaust the stack. Affected: the Python C++ accelerator (the pure-Python protocols are not affected), the PHP library and its thrift_protocol extension, and the Perl, Lua, Smalltalk and OCaml libraries. This issue affects Apache Thrif…
Summary: CVE record, as of .
- CISA has not added CVE-2026-66858 to its Known Exploited Vulnerabilities (KEV) catalog, as of 29 Oct 2026.
- The CVE record was published on 2 Oct 2026.
- The CVE record carries a CVSS v4.0 base score of 8.7 (High), given by its CNA.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 0.3% (percentile 23.4), as of 29 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
- CISA's SSVC assessment in the CVE record: exploitation none, automatable yes, technical impact partial.
- The credits in the CVE record name Anthropic (Claude) as finder.
Source: CISA KEV 2026.10.29, as of ; CVE List, as of ; FIRST EPSS, as of . About the data.
Description
Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: skip() does not apply the recursion limit (Python accelerator, PHP, Perl, Lua, Smalltalk, OCaml)
The protocol skip routine in several Apache Thrift bindings did not apply the binding's recursion limit, so a message that nests unknown fields deeply enough can exhaust the stack. Affected: the Python C++ accelerator (the pure-Python protocols are not affected), the PHP library and its thrift_protocol extension, and the Perl, Lua, Smalltalk and OCaml libraries. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Source: CVE List, as of . About the data.
Weakness
CWE-674
- CWE-674: Uncontrolled Recursion
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published |
Known exploited Apache vulnerabilities
- CVE-2016-3081: Apache Struts Command Injection Vulnerability
- CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
- CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability
- CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability
- CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability