VulnTideExploited vulnerabilities, by vendor. Data as of .
Not in CISA KEVPublished CVSS 9.8 criticalEPSS 0.6% probability of exploitation in 30 days
Apache

CVE-2026-76183: Apache Tomcat: Bypass of security constraints for WebSocket endpoints

Is it exploited?

Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.

How likely is exploitation in the next 30 days?
0.6%

Up from 0.4% on .

EPSS score, percentile 46.9 of all scored records. A probability estimated by FIRST, not a report of exploitation.

How severe?
9.8 Critical

CVSS v3.1 base score, from CISA's enrichment of the record

What should I do?

CISA has set no required action, because the vulnerability is not in KEV.

Advisories and patches (1)

Which versions are affected?

Affected

  • 11.0.0-M1 through 11.0.25
  • 10.1.0-M1 through 10.1.59
  • 9.0.0.M1 through 9.0.121
  • 8.5.0 through 8.5.100
  • 7.0.43 through 7.0.109

Unaffected before 7.0.43

Versions by product

Source: CISA KEV 2026.10.29, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.

What to do

Advisories and patches

This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.

Affected products and versions

As listed in the CVE record.

Apache Software Foundation Apache Tomcat
StatusVersions
Affected11.0.0-M1 through 11.0.25
Affected10.1.0-M1 through 10.1.59
Affected9.0.0.M1 through 9.0.121
Affected8.5.0 through 8.5.100
Affected7.0.43 through 7.0.109
Unaffectedbefore 7.0.43

Versions not listed are: unaffected.

Source: CVE List, as of . About the data.

About this vulnerability

Authentication Bypass by Alternate Name vulnerability in Apache Tomcat allowed the security constraints for any WebSocket endpoint to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121. The following versions were EOS at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5…

Summary: CVE record, as of .

  • CISA has not added CVE-2026-76183 to its Known Exploited Vulnerabilities (KEV) catalog, as of 29 Oct 2026.
  • The CVE record was published on 23 Sep 2026.
  • The CVE record carries a CVSS v3.1 base score of 9.8 (Critical), taken from CISA's enrichment of the record.
  • FIRST's EPSS model puts the probability of exploitation in the next 30 days at 0.6% (percentile 46.9), as of 29 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
  • CISA's SSVC assessment in the CVE record: exploitation none, automatable yes, technical impact total.

Source: CISA KEV 2026.10.29, as of ; CVE List, as of ; FIRST EPSS, as of . About the data.

Description

Apache Tomcat: Bypass of security constraints for WebSocket endpoints

Authentication Bypass by Alternate Name vulnerability in Apache Tomcat allowed the security constraints for any WebSocket endpoint to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121. The following versions were EOS at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.

Source: CVE List, as of . About the data.

Weakness

CWE-289
  • CWE-289: Authentication Bypass by Alternate Name

CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.

Timeline

DateEvent
CVE record published
CVE record last updated

Known exploited Apache vulnerabilities

  • CVE-2016-3081: Apache Struts Command Injection Vulnerability (added )
  • CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability (added )
  • CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability (added )
  • CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability (added )
  • CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability (added )