CVE-2026-85312: Apache Camel: Camel-Core Saga Participation Hijacking via the Unfiltered Long-Running-Action Header
- Is it exploited?
Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.
- How likely is exploitation in the next 30 days?
- 0.3%
EPSS score, percentile 18.9 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 4.8 Medium
CVSS v3.1 base score, given by the CNA
- What should I do?
Upgrade to Apache Camel 4.23.0, which fixes the issue. Full textSolution from the CVE record.
CISA has set no required action, because the vulnerability is not in KEV.
- Which versions are affected?
Affected
- from 4.0.0 to before 4.18.5
- from 4.19.0 to before 4.22.1
Unaffected 4.18.5; 4.22.1; 4.23.0
Source: CISA KEV 2026.10.29, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
What to do
Solution (from the CVE record)
Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The header is now consulted only for a saga service that actually uses it, rather than on every exchange.
Workaround (from the CVE record)
For deployments that cannot upgrade immediately, strip the header at the trust boundary with removeHeaders("Long-Running-Action") on every consumer that accepts messages from an untrusted sender.
Advisories and patches
- Fix on main, released in 4.23.0 (commit dfde003151a0753f997f9eea7d071097f4b00db2)
- Backport to camel-4.22.x, released in 4.22.1 (commit 260989268cbc6d258b1fcba63770be8ebbec40cb)
- Backport to camel-4.18.x, released in 4.18.5 (commit af1efbcccf5882b1ef0094db718972da3190e7e9)
- Apache Camel Security Advisory - CVE-2026-85312
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | from 4.0.0 to before 4.18.5 |
| Affected | from 4.19.0 to before 4.22.1 |
| Unaffected | 4.18.5 |
| Unaffected | 4.22.1 |
| Unaffected | 4.23.0 |
Versions not listed are: unaffected.
Versions the record lists as unaffected: 4.18.5, 4.22.1, 4.23.0.
Source: CVE List, as of . About the data.
About this vulnerability
Improper Input Validation vulnerability in Apache Camel Core component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The saga processor consulted a header named Long-Running-Action to decide which saga an exchange belonged to. The name carries no Camel prefix, so it sits outside the namespace that consumer header filters block, and an external sender cou…
Summary: CVE record, as of .
- CISA has not added CVE-2026-85312 to its Known Exploited Vulnerabilities (KEV) catalog, as of 29 Oct 2026.
- The CVE record was published on 19 Oct 2026.
- The CVE record carries a CVSS v3.1 base score of 4.8 (Medium), given by its CNA.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 0.3% (percentile 18.9), as of 29 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
- CISA's SSVC assessment in the CVE record: exploitation none, automatable no, technical impact partial.
- The credits in the CVE record name Anthropic (Claude) as finder.
Source: CISA KEV 2026.10.29, as of ; CVE List, as of ; FIRST EPSS, as of . About the data.
Description
Apache Camel: Camel-Core Saga Participation Hijacking via the Unfiltered Long-Running-Action Header
Improper Input Validation vulnerability in Apache Camel Core component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. The saga processor consulted a header named Long-Running-Action to decide which saga an exchange belonged to. The name carries no Camel prefix, so it sits outside the namespace that consumer header filters block, and an external sender could supply it on an inbound message. That let the sender name the saga the exchange joined, attaching their request to a long-running action started by someone else, or causing compensation to be associated with an action they did not initiate. The header is only consulted by a saga service that uses it, which bounds the exposure to deployments running sagas over an LRA coordinator. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. The header is now consulted only for a saga service that actually uses it, rather than on every exchange. For deployments that cannot upgrade immediately, strip the header at the trust boundary with removeHeaders("Long-Running-Action") on every consumer that accepts messages from an untrusted sender.
Source: CVE List, as of . About the data.
Weakness
CWE-20
- CWE-20: Improper Input Validation
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published |
References
1
Known exploited Apache vulnerabilities
- CVE-2016-3081: Apache Struts Command Injection Vulnerability
- CVE-2026-34486: Apache Tomcat Missing Encryption of Sensitive Data Vulnerability
- CVE-2026-34197: Apache ActiveMQ Improper Input Validation Vulnerability
- CVE-2024-38475: Apache HTTP Server Improper Escaping of Output Vulnerability
- CVE-2025-24813: Apache Tomcat Path Equivalence Vulnerability