CVE-2026-90970: Improper Neutralization of Special Elements Used in a Template Engine in GitLab AI Gateway
- Is it exploited?
Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.
- How likely is exploitation in the next 30 days?
- 17.5%
EPSS score, percentile 97.1 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 9.9 Critical
CVSS v3.1 base score, given by the CNA
- What should I do?
Upgrade to version 19.2.4, 19.3.2, 19.4.1 or above.Solution from the CVE record.
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- from 18.1.6 to before 19.2.4
- from 19.3 to before 19.3.2
- from 19.4 to before 19.4.1
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
What to do
Solution (from the CVE record)
Upgrade to version 19.2.4, 19.3.2, 19.4.1 or above.
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | from 18.1.6 to before 19.2.4 |
| Affected | from 19.3 to before 19.3.2 |
| Affected | from 19.4 to before 19.4.1 |
Versions not listed are: unaffected.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
About this vulnerability
GitLab has remediated a vulnerability in the GitLab AI Gateway component affecting all versions of the AI Gateway from 18.1.6 before 19.2.4, 19.3 before 19.3.2, and 19.4 before 19.4.1 that, under certain conditions, could have allowed an authenticated user with Duo Agent Platform access to escape the prompt template sandbox via a specially crafted flow configuration, resulting in arbitrary comman…
Summary: CVE record, as of .
- CISA has not added CVE-2026-90970 to its Known Exploited Vulnerabilities (KEV) catalog, as of 28 Oct 2026.
- The CVE record was published on 2 Oct 2026.
- The CVE record carries a CVSS v3.1 base score of 9.9 (Critical), given by its CNA.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 17.5% (percentile 97.1), as of 28 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
- CISA's SSVC assessment in the CVE record: exploitation none, automatable no, technical impact total.
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.
Description
Improper Neutralization of Special Elements Used in a Template Engine in GitLab AI Gateway
GitLab has remediated a vulnerability in the GitLab AI Gateway component affecting all versions of the AI Gateway from 18.1.6 before 19.2.4, 19.3 before 19.3.2, and 19.4 before 19.4.1 that, under certain conditions, could have allowed an authenticated user with Duo Agent Platform access to escape the prompt template sandbox via a specially crafted flow configuration, resulting in arbitrary command execution on the AI Gateway.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
Weakness
- CWE-1336: Improper Neutralization of Special Elements Used in a Template Engine
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published |
References
Known exploited GitLab vulnerabilities
- CVE-2026-85706: GitLab Community Edition and Enterprise Edition Path Traversal Vulnerability
- CVE-2021-22175: GitLab Server-Side Request Forgery (SSRF) Vulnerability
- CVE-2021-39935: GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) Vulnerability
- CVE-2023-7028: GitLab Community and Enterprise Editions Improper Access Control Vulnerability
- CVE-2021-22205: GitLab Community and Enterprise Editions Remote Code Execution Vulnerability