CVE-2026-97229: Integer Overflow or Wraparound in GitLab
- Is it exploited?
Not on CISA's list. CISA has not added it to the Known Exploited Vulnerabilities catalog as of . If CISA adds it, this page shows it as known exploited.
- How likely is exploitation in the next 30 days?
- 18.4%
EPSS score, percentile 97.2 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 10.0 Critical
CVSS v3.1 base score, given by the CNA
- What should I do?
Upgrade to versions 19.2.8, 19.3.5, 19.4.2 or above.Solution from the CVE record.
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- from 19.2 to before 19.2.8
- from 19.3 to before 19.3.5
- from 19.4 to before 19.4.2
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
What to do
Solution (from the CVE record)
Upgrade to versions 19.2.8, 19.3.5, 19.4.2 or above.
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | from 19.2 to before 19.2.8 |
| Affected | from 19.3 to before 19.3.5 |
| Affected | from 19.4 to before 19.4.2 |
Versions not listed are: unaffected.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
About this vulnerability
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
Summary: CVE record, as of .
- CISA has not added CVE-2026-97229 to its Known Exploited Vulnerabilities (KEV) catalog, as of 28 Oct 2026.
- The CVE record was published on 13 Oct 2026.
- The CVE record carries a CVSS v3.1 base score of 10.0 (Critical), given by its CNA.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 18.4% (percentile 97.2), as of 28 Oct 2026. EPSS is a statistical estimate, not a report of exploitation.
- CISA's SSVC assessment in the CVE record: exploitation none, automatable yes, technical impact total.
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.
Description
Integer Overflow or Wraparound in GitLab
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
Weakness
- CWE-190: Integer Overflow or Wraparound
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
References
Known exploited GitLab vulnerabilities
- CVE-2026-85706: GitLab Community Edition and Enterprise Edition Path Traversal Vulnerability
- CVE-2021-22175: GitLab Server-Side Request Forgery (SSRF) Vulnerability
- CVE-2021-39935: GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) Vulnerability
- CVE-2023-7028: GitLab Community and Enterprise Editions Improper Access Control Vulnerability
- CVE-2021-22205: GitLab Community and Enterprise Editions Remote Code Execution Vulnerability