CVE-2020-2034: PAN-OS: OS command injection vulnerability in GlobalProtect portal
- Is it exploited?
Reported, not confirmed by CISA. VulnCheck KEV lists it as exploited in the wild. CISA has not added it to its Known Exploited Vulnerabilities catalog as of .
VulnCheck KEV lists it since . It cites 2 public reports, the first from .
- How likely is exploitation in the next 30 days?
- 7.2%
EPSS score, percentile 94.3 of all scored records. A probability estimated by FIRST, not a report of exploitation.
- How severe?
- 8.1 High
CVSS v3.1 base score, given by the CNA
- What should I do?
This issue is fixed in PAN-OS 8.1.15, PAN-OS 9.0.9, PAN-OS 9.1.3, and all later PAN-OS versions.Solution from the CVE record.
CISA has set no required action, because the vulnerability is not in KEV.
The CVE record links no vendor advisory, patch or mitigation.
- Which versions are affected?
Affected
- 8.0.*
- 7.1.*
- from 9.1 to before 9.1.3
- from 9.0 to before 9.0.9
- from 8.1 to before 8.1.15
Unaffected from 9.1.3; from 9.0.9; from 8.1.15
Source: CISA KEV 2026.10.29, as of ; VulnCheck KEV, as of ; FIRST EPSS, as of ; CVE List, as of . About the data.
Description
PAN-OS: OS command injection vulnerability in GlobalProtect portal
An OS Command Injection vulnerability in the PAN-OS GlobalProtect portal allows an unauthenticated network based attacker to execute arbitrary OS commands with root privileges. An attacker requires some knowledge of the firewall to exploit this issue. This issue can not be exploited if GlobalProtect portal feature is not enabled. This issue impacts PAN-OS 9.1 versions earlier than PAN-OS 9.1.3; PAN-OS 8.1 versions earlier than PAN-OS 8.1.15; PAN-OS 9.0 versions earlier than PAN-OS 9.0.9; all versions of PAN-OS 8.0 and PAN-OS 7.1. Prisma Access services are not impacted by this vulnerability.
Source: CVE List, as of . About the data.
What to do
Advisories and patches
The CVE record links no vendor advisory, patch or mitigation.
Solution (from the CVE record)
PAN-OS 7.1 and PAN-OS 8.0 are end-of-life (as of June 30, 2020 and October 31, 2019 respectively) and are no longer covered by our Product Security Assurance policies.
This summary is based on the CVE record as of . Check the vendor's advisory before you act: affected versions and fixes can change.
Affected products and versions
Versions by product, as listed in the CVE record (1 product)
| Status | Versions |
|---|---|
| Affected | 8.0.* |
| Affected | 7.1.* |
| Affected | from 9.1 to before 9.1.3 |
| Unaffected | from 9.1.3 |
| Affected | from 9.0 to before 9.0.9 |
| Unaffected | from 9.0.9 |
| Affected | from 8.1 to before 8.1.15 |
| Unaffected | from 8.1.15 |
Versions the record lists as unaffected: 9.1.3, 9.0.9, 8.1.15.
Source: CVE List, as of . About the data.
Weakness
CWE-78
- CWE-78: OS Command Injection
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| CVE record last updated |
References
1
Known exploited Palo Alto Networks vulnerabilities
- CVE-2026-0322: Palo Alto Networks PAN-OS Code Injection Vulnerability
- CVE-2026-0257: Palo Alto Networks PAN-OS Authentication Bypass Vulnerability
- CVE-2026-0300: Palo Alto Networks PAN-OS Out-of-bounds Write Vulnerability
- CVE-2025-0111: Palo Alto Networks PAN-OS File Read Vulnerability
- CVE-2025-0108: Palo Alto Networks PAN-OS Authentication Bypass Vulnerability