CVE-2026-105133: Ahsay AhsayCBS Improper Authentication Vulnerability
- Is it exploited?
Yes. CISA added it to the Known Exploited Vulnerabilities catalog on 14 Oct 2026, 10 days after the CVE record was published.
- How likely is exploitation in the next 30 days?
- 79.5%
EPSS score, percentile 99.6 of all scored records
- How severe?
- 6.9 Medium
CVSS v4.0 base score, given by the CNA
- What should I do?
CISA deadline 17 Oct 2026. Apply mitigations in accordance with vendor instructions … Full text
- Which versions are affected?
Affected
- 9.15.2.0
- 9.15.2.1
- 9.15.2.2
- 9.15.2.3
- 9.15.2.4
- 9.15.2.5
and 6 more in the table below
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of 28 Oct 2026; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of 28 Oct 2026; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
What to do
Required action, set by CISA
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
CISA due date for this action: 17 October 2026.
Advisories and patches
Linked from CISA's catalog entry
- https://www.ahsay.com/en/company/announcements/patch-cve-105133-105134-update
- https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk
- https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk
- https://nvd.nist.gov/vuln/detail/CVE-2026-105133
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | 9.15.2.0 |
| Affected | 9.15.2.1 |
| Affected | 9.15.2.2 |
| Affected | 9.15.2.3 |
| Affected | 9.15.2.4 |
| Affected | 9.15.2.5 |
| Affected | 9.15.2.6 |
| Affected | 9.15.2.7 |
| Affected | 9.15.2.8 |
| Affected | 9.15.2.9 |
| Affected | 9.15.2.10 |
| Affected | 9.15.2.11 |
And 105 more version entries in the CVE record.
Versions the record lists as unaffected: 9.15.2.70, 10.3.4.45.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
About this vulnerability
Ahsay AhsayCBS contains an improper authentication vulnerability that could allow a remote attacker to bypass authentication via manipulation of the random parameter in the API component’s checkSysPwd function. This vulnerability can be chained with CVE-2026-105134.
Summary: CISA's KEV catalog, as of 28 Oct 2026.
- CISA added CVE-2026-105133 to its Known Exploited Vulnerabilities (KEV) catalog on 14 Oct 2026.
- CISA's ransomware flag for this entry is "Unknown": no evidence of ransomware use in the catalog, which is not proof of none.
- The due date CISA sets for the required action is 17 Oct 2026.
- The CVE record was published on 4 Oct 2026, 10 days before it was added to KEV.
- The CVE record carries a CVSS v4.0 base score of 6.9 (Medium), given by its CNA.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 79.5% (percentile 99.6), as of 28 Oct 2026.
- CISA's SSVC assessment in the CVE record: exploitation active, automatable yes, technical impact partial.
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of 28 Oct 2026; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of 28 Oct 2026. About the data.
Description
Ahsay AhsayCBS API ApiStructsAction.java checkSysPwd improper authentication
A vulnerability was detected in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to mitigate this issue. It is recommended to upgrade the affected component. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of 28 Oct 2026. About the data.
Weakness
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record and the KEV entry.
Timeline
| Date | Event |
|---|---|
| 4 Oct 2026 | CVE record published |
| 14 Oct 2026 | Added to CISA KEV |
| 17 Oct 2026 | CISA due date for the required action |
| 26 Oct 2026 | CVE record last updated |
References
- CVE-2026-105133 | CVE Analysis and Report
- Submit #942688 | Ahsay Systems Corporation Limited AhsayCBS 10.0.3 Authentication Bypass
- VDB-413350 | Ahsay AhsayCBS API ApiStructsAction.java checkSysPwd improper authentication
- huntress.com
- VDB-413350 | CTI Indicators (IOB, IOC, IOA)
More exploited Ahsay vulnerabilities
- CVE-2026-105134: Ahsay AhsayCBS Command Injection Vulnerability