CVE-2026-105134: Ahsay AhsayCBS Command Injection Vulnerability
- Is it exploited?
Yes. CISA added it to the Known Exploited Vulnerabilities catalog on , 10 days after the CVE record was published.
- How likely is exploitation in the next 30 days?
- 81.8%
EPSS score, percentile 99.6 of all scored records
- How severe?
- 10.0 Critical
CVSS v4.0 base score, given by the CNA
- What should I do?
CISA deadline . Apply mitigations in accordance with vendor instructions … Full text
- Which versions are affected?
Affected
- 9.15.2.0
- 9.15.2.1
- 9.15.2.2
- 9.15.2.3
- 9.15.2.4
- 9.15.2.5
and 6 more in the table below
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
What to do
Required action, set by CISA
Apply mitigations in accordance with vendor instructions, ensuring compliance with CISA’s BOD 26-04 Prioritizing Security Updates Based on Risk (see URL in Notes) guidance and CISA’s “Forensics Triage Requirements” (see URL in Notes). Follow applicable BOD 26-04 guidance for cloud services or discontinue use of the product if mitigations are unavailable. Stakeholders are responsible for evaluating each asset's internet exposure and ensuring adherence to BOD 26-04 patching guidelines.
CISA due date for this action: .
Advisories and patches
Linked from CISA's catalog entry
- https://www.ahsay.com/en/company/announcements/patch-cve-105133-105134-update
- https://www.cisa.gov/news-events/directives/bod-26-04-prioritizing-security-updates-based-risk
- https://www.cisa.gov/news-events/directives/bod-26-04-implementation-guidance-prioritizing-security-updates-based-risk
- https://nvd.nist.gov/vuln/detail/CVE-2026-105134
Affected products and versions
As listed in the CVE record.
| Status | Versions |
|---|---|
| Affected | 9.15.2.0 |
| Affected | 9.15.2.1 |
| Affected | 9.15.2.2 |
| Affected | 9.15.2.3 |
| Affected | 9.15.2.4 |
| Affected | 9.15.2.5 |
| Affected | 9.15.2.6 |
| Affected | 9.15.2.7 |
| Affected | 9.15.2.8 |
| Affected | 9.15.2.9 |
| Affected | 9.15.2.10 |
| Affected | 9.15.2.11 |
And 105 more version entries in the CVE record.
Versions the record lists as unaffected: 9.15.2.70, 10.3.4.45.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
About this vulnerability
Ahsay AhsayCBS contains a command injection vulnerability that could allow a remote attacker to execute operating system commands via manipulation of the random parameter in the Replication Receiver component’s /rps/api/json/UpdateReceivers.do endpoint. This vulnerability can be chained with CVE-2026-105133.
Summary: CISA's KEV catalog, as of .
- CISA added CVE-2026-105134 to its Known Exploited Vulnerabilities (KEV) catalog on 14 Oct 2026.
- CISA's ransomware flag for this entry is "Unknown": no evidence of ransomware use in the catalog, which is not proof of none.
- The due date CISA sets for the required action is 17 Oct 2026.
- The CVE record was published on 4 Oct 2026, 10 days before it was added to KEV.
- The CVE record carries a CVSS v4.0 base score of 10.0 (Critical), given by its CNA.
- FIRST's EPSS model puts the probability of exploitation in the next 30 days at 81.8% (percentile 99.6), as of 28 Oct 2026.
- CISA's SSVC assessment in the CVE record: exploitation active, automatable yes, technical impact total.
Source: CISA Known Exploited Vulnerabilities (KEV) catalog, 2026.10.28, as of ; CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of ; FIRST Exploit Prediction Scoring System (EPSS), v2026.06.15, as of . About the data.
Description
Ahsay AhsayCBS Replication Receiver UpdateReceivers.do os command injection
A flaw has been found in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This vulnerability affects unknown code of the file /rps/api/json/UpdateReceivers.do of the component Replication Receiver. Executing a manipulation of the argument random can lead to os command injection. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to resolve this issue. Upgrading the affected component is advised. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.
Source: CVE List V5 (CVE Program), cve_2026-10-28_0000Z, as of . About the data.
Weakness
CWE and CAPEC are maintained by MITRE; the entries are those named in the CVE record and the KEV entry.
Timeline
| Date | Event |
|---|---|
| CVE record published | |
| Added to CISA KEV | |
| CISA due date for the required action | |
| CVE record last updated |
References
- CVE-2026-105134 | CVE Analysis and Report
- Submit #942743 | Ahsay Systems Corporation Limited Ahsay CBS 10.3.0 Remote Code Execution via Arbitrary File Write
- VDB-413351 | Ahsay AhsayCBS Replication Receiver UpdateReceivers.do os command injection
- huntress.com
- VDB-413351 | CTI Indicators (IOB, IOC, TTP, IOA)
More exploited Ahsay vulnerabilities
- CVE-2026-105133: Ahsay AhsayCBS Improper Authentication Vulnerability